hdu2955(01背包)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7975    Accepted Submission(s): 3018


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

hdu2955(01背包)_第1张图片
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
   
   
   
   
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
   
   
   
   
2 4 6
 

Source
IDI Open 2009
 

Recommend
gaojie
 
本题要求被抓概率小于p的情况下抢劫的最多金额。
对于每个银行,有抢与不抢两种情况,可以想到类比01背包。一种直观的想法把最小概率p当做最大载重量,把抢劫的金额当做物品的价值。但概率是浮点数,不好离散处理。
另一种想法可以把所有银行总的金额当做容量,做容量一定的情况下尽可能地使被抓概率下,即不被抓概率大。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

double dp[100*100+10];
int val[100+10];
double Caup[100+10];


int main()
{
	int cas,i,n,sum,j;
	double Maxp;
	cin>>cas;
	while(cas--)
	{
		scanf("%lf%d",&Maxp,&n);
		sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%lf",&val[i],&Caup[i]);
			sum+=val[i];
		}
		
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		for(i=0;i<n;i++)
		{
			for(j=sum;j>=val[i];j--)
			{
				if(dp[j]<dp[j-val[i]]*(1-Caup[i]))
					dp[j]=dp[j-val[i]]*(1-Caup[i]);
			}
		}
		int ans=0;
		for(j=0;j<=sum;j++)
		{
			if(1-dp[j]<Maxp)
				ans=j;
		}
		printf("%d\n",ans);
		
	}
	return 0;
}

你可能感兴趣的:(动态规划)