hdu2392(多重背包)

Space Elevator
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7154   Accepted: 3353

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000).

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS:

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

USACO 2005 March Gold
 
首先声明这题是转载大牛的,转载网址 http://www.cnblogs.com/kuangbin/archive/2012/09/20/2694686.html
 
本题给定若干种砖块、每种砖块的高度、该种砖块的数量、以及该砖块所能达到的最大高度,然后求这些砖块所能垒成的最大高度。
如果放下砖块垒成的最大高度不考虑,就是一个典型的多重背包问题。可以考虑对这些砖块按所能达到的最高高度从小到大排过序,就转化成了一个多重背包。这点想想是完全正确且非常巧妙的。本题在做多重背包时也是需要优化的,将每种物品的1,2,4,8…2^(k-1),num-(2^k-1)的对应高度、对应数量的新物品。
本题多重背包的实现堪比模板,好好好!建议大家用它做模板。
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=410;

struct Node
{
    int h,c;
    int lim;
}node[MAXN];
int dp[50000];
int H;
void ZeroOnePack(int cost,int weight,int lim)
{
    for(int i=lim;i>=cost;i--)
       dp[i]=max(dp[i],dp[i-cost]+weight);
}

void CompletePack(int cost,int weight,int lim)
{
    for(int i=cost;i<=lim;i++)
      dp[i]=max(dp[i],dp[i-cost]+weight);
}

void MultiplePack(int cost,int weight,int amount,int lim)
{
    if(cost*amount>=lim)CompletePack(cost,weight,lim);
    else
    {
        for(int k=1;k<amount;)
        {
            ZeroOnePack(k*cost,k*weight,lim);
            amount-=k;
            k<<=1;
        }
        ZeroOnePack(amount*cost,amount*weight,lim);
    }
}

bool cmp(Node a,Node b)
{
    return a.lim<b.lim;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        H=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&node[i].h,&node[i].lim,&node[i].c);
            if(node[i].lim>H)H=node[i].lim;
        }
        for(i=0;i<=H;i++)dp[i]=0;
        sort(node,node+n,cmp);
        for(i=0;i<n;i++)
          MultilePack(node[i].h,node[i].h,node[i].c,node[i].lim);
        int ans=0;
        for(int i=0;i<=H;i++)ans=max(ans,dp[i]);//这个过程一定要
        printf("%d\n",ans);
    }
    return 0;
}

 

你可能感兴趣的:(动态规划)