hdoj 4135 Co-prime 【容斥原理】

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1882    Accepted Submission(s): 722


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
   
   
   
   
2 1 10 2 3 15 5
 

Sample Output
   
   
   
   
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 


容斥原理:队列实现

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<stack>
#include<algorithm>
#include<iostream>
using namespace std;
long long p[100],k;
void getp(long long n)
{
	long long i;
	k=0;
	for(i=2;i*i<=n;i++)
	{
		if(n%i==0)
		p[k++]=i;
		while(n%i==0)
		n/=i;
	}
	if(n>1)
	p[k++]=n;
}
long long nop(long long m)
{
	long long que[100000],i,j,sum,top=0,t;
	que[top++]=-1;
	for(i=0;i<k;i++)
	{
		t=top;
		for(j=0;j<t;j++)
		{
			que[top++]=que[j]*p[i]*(-1);
		}
	}
	for(i=1,sum=0;i<top;i++)
	sum+=m/que[i];
	return sum;
}
int main()
{
	long long a,b,n;
	int t,j=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld%lld",&a,&b,&n);
		getp(n);
		printf("Case #%d: %lld\n",j++,b-nop(b)-(a-1-nop(a-1)));
	}
	return 0;
}


 

更新2015.6.14


 位运算:

 

#include <cstdio>
#include <cstring>
#define LL long long
LL p[100], k;
void getp(LL n)
{
	LL i;
	k = 0;
	for(i = 2; i*i <= n; i++)
	{
		if(n % i == 0)
		{
			p[k++] = i;
			while(n % i == 0)
			n /= i;
		}
	} 
	if(n > 1) p[k++] = n;
}
LL nop(LL m)
{
	LL i, j;
	LL use, res;
	LL sum = 0;
	for(i = 1; i < 1<<k; i++)
	{
		use = 0;
		res = 1;
		for(j = 0; j < k; j++)
		{
			if(i & (1<<j))
			{
				use++;
				res *= p[j];
			}
		}
		if(use & 1) sum += m / res;
		else sum -= m / res;
	} 
	return sum;
}
int main()
{
	int t;
	int j = 1;
	LL a, b, n;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%lld%lld%lld", &a, &b, &n);
		getp(n);
		printf("Case #%d: %lld\n", j++, b-nop(b)-(a-1-nop(a-1)));
	}
	return 0;
}




 

你可能感兴趣的:(hdoj 4135 Co-prime 【容斥原理】)