BZOJ 1611: [Usaco2008 Feb]Meteor Shower流星雨

 

1611: [Usaco2008 Feb]Meteor Shower流星雨

Description

去年偶们湖南遭受N年不遇到冰冻灾害,现在芙蓉哥哥则听说另一个骇人听闻的消息: 一场流星雨即将袭击整个霸中,由于流星体积过大,它们无法在撞击到地面前燃烧殆尽, 届时将会对它撞到的一切东西造成毁灭性的打击。很自然地,芙蓉哥哥开始担心自己的 安全问题。以霸中至In型男名誉起誓,他一定要在被流星砸到前,到达一个安全的地方 (也就是说,一块不会被任何流星砸到的土地)。如果将霸中放入一个直角坐标系中, 芙蓉哥哥现在的位置是原点,并且,芙蓉哥哥不能踏上一块被流星砸过的土地。根据预 报,一共有M颗流星(1 <= M <= 50,000)会坠落在霸中上,其中第i颗流星会在时刻 T_i (0 <= T_i <= 1,000)砸在坐标为(X_i, Y_i) (0 <= X_i <= 300;0 <= Y_i <= 300) 的格子里。流星的力量会将它所在的格子,以及周围4个相邻的格子都化为焦土,当然 芙蓉哥哥也无法再在这些格子上行走。芙蓉哥哥在时刻0开始行动,它只能在第一象限中, 平行于坐标轴行动,每1个时刻中,她能移动到相邻的(一般是4个)格子中的任意一个, 当然目标格子要没有被烧焦才行。如果一个格子在时刻t被流星撞击或烧焦,那么芙蓉哥哥 只能在t之前的时刻在这个格子里出现。请你计算一下,芙蓉哥哥最少需要多少时间才能到 达一个安全的格子。

Input

* 第1行: 1个正整数:M * 第2..M+1行: 第i+1行为3个用空格隔开的整数:X_i,Y_i,以及T_i

Output

输出1个整数,即芙蓉哥哥逃生所花的最少时间。如果芙蓉哥哥无论如何都无法在流星雨中存活下来,输出-1

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5
输入说明:
一共有4颗流星将坠落在霸中,它们落地点的坐标分别是(0, 0),(2, 1),(1, 1)
以及(0, 3),时刻分别为2,2,2,5。

* = 流星落点 # = 行走禁区
t = 0 t = 2 t = 5
5|. . . . . . . 5|. . . . . . . 5|. . . . . . .
4|. . . . . . . 4|. . . . . . . 4|# . . . . . .
3|. . . . . . . 3|. . . . . . . 3|* # . . . . .
2|. . . . . . . 2|. # # . . . . 2|# # # . . . .
1|. . . . . . . 1|# * * # . . . 1|# # # # . . .
0|B . . . . . . 0|* # # . . . . 0|# # # . . . .
-------------- -------------- --------------
0 1 2 3 4 5 6 0 1 2 3 4 5 6 0 1 2 3 4 5 6


Sample Output

5
输出说明:
如果我们观察在t=5时的霸中,可以发现离芙蓉哥哥最近的安全的格子是
(3,0)——不过由于早在第二颗流星落地时,芙蓉哥哥直接跑去(3,0)的路线就被封死了。
离芙蓉哥哥第二近的安全格子为(4,0),但它的情况也跟(3,0)一样。再接下来的格子就是在
(0,5)-(5,0)这条直线上。在这些格子中,(0,5),(1,4)以及(2,3)都能在5个单位时间内到达。

5|. . . . . . .
4|. . . . . . .
3|3 4 5 . . . . 某个合法的逃生方案中
2|2 . . . . . . 芙蓉哥哥每个时刻所在地点
1|1 . . . . . .
0|0 . . . . . .
--------------
0 1 2 3 4 5 6

 

 

——华丽的分割线——

这道题目就是一开始求出所有安全的地方,然后模拟就可以了。人先向外扩张一个,然后在用流星毁一下地图,重复到人必死或者安全为止、

有个心态很不好的地方就是、这道题目如果走出300*300这个区域,是算安全的!【卧槽!害我Wa了好多次,这不是坑爹吗!什么心态!

代码:

#include<cstdio>

#include<algorithm>

#include<queue>

using namespace std;



int Dx[]={0,0,1,0,-1};

int Dy[]={0,1,0,-1,0}; 



bool isDestroyed[310][310];

bool mapDestroyed[310][310];

bool inQueue[310][310];



int m;

struct TPointNode{

	int x;

	int y;

	int t;

};

TPointNode point[50010];

int index;

inline bool cmp(TPointNode a,TPointNode b){

	if (a.t<b.t) return true;

	return false;

}



struct PointNode{

	PointNode(){}

	PointNode(int a,int b){

		x=a;y=b;

	}

	int x;

	int y;

};

queue<PointNode> que;

int NowTime;



inline void getDestroyPlace(){

	for (int i=1;i<=m;i++){

		for (int k=0;k<=4;k++){

			int x=Dx[k]+point[i].x,y=Dy[k]+point[i].y;

			if (0<=x && x<=300 && 0<=y && y<=300) isDestroyed[x][y]=true;

		}

	}	

}



inline bool BFS(){

	queue<PointNode> inque;

	while(!que.empty()){

		PointNode NowNode=que.front();

		int nx=NowNode.x,ny=NowNode.y;

		que.pop();

		if (mapDestroyed[nx][ny]==true) continue;

		for (int k=1;k<=4;k++){

			int x=Dx[k]+nx,y=Dy[k]+ny;

			if (0<=x && 0<=y){

				if (isDestroyed[x][y]==false) {

					return true;

				}

				if (x>300 || y>300) return true;

				if (inQueue[x][y]==false){

					inQueue[x][y]=true;

					inque.push(PointNode(x,y));

				}

			}

		}

	}

	que=inque;

	return false;

}



int main(){

	scanf("%d\n",&m);

	for (int i=1;i<=m;i++) scanf("%d%d%d",&point[i].x,&point[i].y,&point[i].t);

	

	getDestroyPlace();

	

	sort(point+1,point+m+1,cmp);

	NowTime=0;

	index=1;

	que.push(PointNode(0,0));

	while(point[index].t==0){

		for (int k=0;k<=4;k++){

			int x=Dx[k]+point[index].x,y=Dy[k]+point[index].y;

			if (0<=x && x<=300 && 0<=y && y<=300) mapDestroyed[x][y]=true;

		}

		index++;

	}

	for (;index<=m;){

		NowTime++;

		if (BFS()) {

			printf("%d\n",NowTime);

			return 0;

		}

		while(point[index].t==NowTime){

			for (int k=0;k<=4;k++){

				int x=Dx[k]+point[index].x,y=Dy[k]+point[index].y;

				if (0<=x && x<=300 && 0<=y && y<=300) mapDestroyed[x][y]=true;

			}

			index++;

		}

	}

	printf("-1\n");

	

	return 0;

}



 

你可能感兴趣的:(USACO)