Dragon Balls 3635 (并查集求深度) 好题

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4571    Accepted Submission(s): 1741


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.
Dragon Balls 3635 (并查集求深度) 好题_第1张图片
His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
   
   
   
   
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
   
   
   
   
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 
#include<stdio.h>
#include<string.h>
int n,m;
int a[11000];
int b[11000];//记录相应城市龙珠的总数 
int s[11000];//记录深度 ,(对应的龙珠上面有几层,它就被转移了几次) 
int find(int x)
{
	if(x!=a[x])
	{
		int t=a[x];
		a[x]=find(a[x]);
		s[x]+=s[t];
	}
	return a[x];
}
int marge(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	{
		a[fx]=fy;//将 x 所在的根节点 连到 y下面 
		s[fx]=1;
		b[fy]+=b[fx];//不断更新龙珠的个数(根节点下面的龙珠个数) 
		b[fx]=0;	 //将原来 x 所在的城市的龙珠个数记录为0,因为龙珠已被转走	
	}
}
int main(){
	int i,j,k=1,t,x,y;
	scanf("%d",&t);
	while(t--)
	{
		printf("Case %d:\n",k++);
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		{
			a[i]=i;
			b[i]=1;
			s[i]=0;
		}		
		char c;
		while(m--)
		{						
			getchar();
			scanf("%c",&c);
			if(c=='T')
			{
				scanf("%d%d",&x,&y);
				marge(x,y);
			}
			else
			{
				scanf("%d",&x);
				int dx=find(x);//求出相应龙珠的根节点 
				printf("%d %d %d\n",dx,b[dx],s[x]);
			}
		}
	}
	return 0;
}

你可能感兴趣的:(Dragon Balls 3635 (并查集求深度) 好题)