数论欧拉函数

A - Bi-shoe and Phi-shoe
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit  Status  Practice  LightOJ 1370

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:

老师给学生买竹子,每个学生都有一个幸运数字,要买竹子长度 n 的欧拉函数 大于等于 学生的幸运数字才可以,以单位长度竹子一块钱(大概这个意思),现在要求出最小花费

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int maxn=1500000;
int foul[maxn+5];///表示 反欧拉 函数表
int oul[maxn+5];///欧拉函数 表
void get_foul()
{
    memset(oul,0,sizeof(oul));
    for(int i=2;i<=maxn;i++)
    {
        if(!oul[i])
        {
            for(int j=i;j<=maxn;j+=i)
            {
                 if(!oul[j])
                oul[j]=j;
                oul[j]=oul[j]/i*(i-1);
            }

        }
    }/// 求得 oula【】
    for(int i=1;i<=maxn;i++)
        oul[i]=max(oul[i],oul[i-1]);///保证欧拉 函数递增
        for(int i=maxn;i>=1;i--)
            foul[oul[i]]=i;///从后向前更反欧拉函数 保证 每一个 foul[i]取最小值
   /// foul[] 取不到的 令其等于后面第一个可以取到的foul[t]
    for(int i=1;i<=maxn;i++)
    {
        if(foul[i]==0)
        {
            int t=i;
            while(foul[t]==0&&t<=maxn)
            {
                t++;
            }
            foul[i]=foul[t];
        }
    }
}
int main()
{
    get_foul();
    int t,n;
    cin>>t;
    for(int i=1; i<=t; i++)
    {
        scanf("%d",&n);
        long long ans=0;
        while(n--)
        {
            int x;
            scanf("%d",&x);
            ans+=foul[x];
        }
        printf("Case %d: %lld Xukha\n",i,ans);
    }
    return 0;
}



你可能感兴趣的:(数论欧拉函数)