ZOJ 3822 Domination (概率期望)

ZOJ 3822 Domination(概率期望):http://acm.hust.edu.cn/vjudge/contest/view.action?cid=115193#problem/E 传送门:nefu

题面描述:

Time Limit:8000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu
Submit  Status

Description

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominatedby the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

题目大意 :

往一个m行n列的棋盘里放置棋子,当棋盘中的每一行和每一列都有棋子占据时,说明棋盘被占据,求向棋盘中放置棋子个数的期望。


题目分析:

本题采用先计算概率,再计算期望的方法。

把概率存在一个三维dp[m][n][k]数组中,且对于每一种情况,dp[i][j][k]=原始状态的概率×选到这样的位置的概率,即对于第k个棋子,我们总是要在第k-1个棋子的基础上进行放置的,所以,放置的第k个棋子,可能刷新行,也可能刷新列,也可能既刷新了行,又刷新了列,还可能既没有刷新行也没有刷新列。


代码实现:

#include <iostream>
#include <cstdio>

using namespace std;

double dp[55][55][2550]; ///2550=50*50+50
int main()
{
    int t;
    int m,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        int sum=m*n;
        for(int i=0;i<=m;i++)
        {
            for(int j=0;j<=n;j++)
            {
                for(int k=0;k<=sum;k++)
                {
                    dp[i][j][k]=0.0;
                }
            }
        }
        dp[0][0][0]=1.0; ///计算概率
        for(int k=1;k<=sum;k++)
        {
            for(int i=1;i<=m;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    dp[i][j][k]+=dp[i][j][k-1]*(i*j-k+1)*1.0/(sum-k+1); ///既不刷新行,也不刷新列
                    dp[i][j][k]+=dp[i][j-1][k-1]*((n-j+1)*i)*1.0/(sum-k+1); ///刷新列
                    dp[i][j][k]+=dp[i-1][j][k-1]*((m-i+1)*j)*1.0/(sum-k+1); ///刷新行
                    dp[i][j][k]+=dp[i-1][j-1][k-1]*(m-i+1)*(n-j+1)*1.0/(sum-k+1); ///既刷新行,又刷新列
                }
            }
        }
        double ans=0;
        for(int k=1;k<=sum;k++) ///计算期望
        {
            ans+=(dp[m][n][k]-dp[m][n][k-1])*k;
        }
        printf("%.12lf\n",ans);
    }
    return 0;
}



你可能感兴趣的:(概率期望)