hdu 1114 Piggy-Bank

一道水的不得了的题,而我却想了好久,甚至还看别人博客,,不过还好没看懂别人写的是什么,凭自己写了出来,,唉~严重怀疑自己能力,题目就是给你一个存钱罐的起初质量和末质量,再给你一些钱币的质量和价值,问你这个存钱罐最少装了多少钱,(当然也可能存钱罐里的质量和这些钱根本不相应,即不存在这种情况),说白了,就是一道很水的完全背包,不过是求所有能装的情况的最小值,只需要将dp数组起初附一个很大的值,然后背包跑一遍,同时背包取最小值,跑完后,若对应的dp数组的最后的一个值仍然等于起初负的值,那么说明这种情况不存在,否则就将这一个值输出。

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19131    Accepted Submission(s): 9694


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
   
   
   
   
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
   
   
   
   
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 

Source
Central Europe 1999

代码:

#include<stdio.h>
#include<string.h>
int dp[10010],w[510],v[510];
#define min(a,b) a<b?a:b
const int inf=1000000000;
int main()
{
    int nn,qizhi,mozhi;
    scanf("%d",&nn);
    while(nn--)
    {
        int n,i,j;
        scanf("%d%d%d",&qizhi,&mozhi,&n);
        int zhong=mozhi-qizhi;
        for(i=1; i<=n; i++)
            scanf("%d%d",&v[i],&w[i]);
        memset(dp,0,sizeof(dp));
        for(i=1; i<=zhong; i++)
            dp[i]=inf;
        for(i=1; i<=n; i++)
            for(j=w[i]; j<=zhong; j++)
                dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
        if(dp[zhong]==inf)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[zhong]);
    }
}

你可能感兴趣的:(动态规划,hdu日常小练)