数学—杭电1009 FatMouse' Trade

http://acm.hdu.edu.cn/showproblem.php?pid=1009

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39812    Accepted Submission(s): 13139

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
   
   
   
   
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 
Sample Output
   
   
   
   
13.333 31.500

 

#include<iostream>//贪心
#include<cstdio>//题目意思:老鼠用m克猫粮和猫兑换自己喜欢的食物,
//但是老鼠喜欢的食物在许多仓库并且每层仓库的兑换率都不相同但是每层的兑换率是J[i]克猫粮兑F[i]食物(i是层数)
#include<cstring>
const int MAX=10001;
int J[MAX];
int F[MAX];
double p[MAX];
using namespace std;
int main()
{
    int n,m,i,j;
    double sum;
    while(cin>>m>>n&&(m!=-1&&n!=-1))
    {
        for(i=1;i<=n;i++)
        {
            cin>>J[i]>>F[i];
            p[i]=double(J[i])/F[i];//每层兑换率
        }
        sum=0;
        while(m!=0&&n!=0)//当猫粮为0或者食物为0时跳出循环
        {
            int k;
            double Max=-1;
            for(i=1;i<=n;i++)//每次挑选兑率最大的层数
            {
                if(p[i]>Max)
                {
                    Max=p[i];//记录最大的兑换率
                    k=i;//记录最大的层数
                }
            }
            if(m-F[k]>=0)//如果猫粮有剩余或者刚好
            {
                m-=F[k];//减去需要的猫粮
                sum+=J[k];//加上兑换到的食物
                p[k]=0;//该层的兑率为0即兑换完了
            }
            else//如果猫粮不够的话,就用剩下的猫粮全部去兑换食物
            {
                sum+=p[k]*m;//全部兑换食物
                m=0;
            }
        }
        printf("%.3lf\n",sum);//输出
    }
    return 0;
}


 

你可能感兴趣的:(数学—杭电1009 FatMouse' Trade)