http://acm.hdu.edu.cn/showproblem.php?pid=1081
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
#include <string.h>
#include <stdio.h>
#include <iostream>
using namespace std;
int a[1005][1005];
int dp[1005][1005];
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
cin >>a[i][j];
dp[i][j]=dp[i][j-1]+dp[i-1][j]-dp[i-1][j-1]+a[i][j];
}
/* for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
cout<< dp[i][j]<< endl;
cout << endl;
}*/
int sum=0,sum1;
int maxx=-99999;
for(int i=1;i<=n;i++)
for(int j=i;j<=n;j++)
{
int sum=0;
for(int k=1;k<=n;k++)
{
sum1=dp[j][k]-dp[i-1][k]-dp[j][k-1]+dp[i-1][k-1];
if(sum>0)
sum+=sum1;
else
sum=sum1;
if(sum>maxx)
maxx=sum;
}
}
printf("%d\n",maxx);
}
return 0;
}
http://blog.csdn.net/yusiguyuan/article/details/12877103