看了好多题目没看懂,当然也怪我英语水平太差啦。将每隔M-1个box看成当前盒子被第M-1个盒子隔开的第一个盒子。
好啦:题目大意就是,N个人围成一个圈,Haha每隔M-1个人找一次。这样可能会找不到。比如说N==8,M==4;先在第一个,然后跳三个,在第5个,再跳三个,在第一个,循环,就只找了1、5两个位置;
那么什么情况会产生这种情况呢,就是当N,M没有公约数的时候;
题目在下方:
hide handkerchief
Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1965 Accepted Submission(s): 903
Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
Output
For each input case, you should only the result that Haha can find the handkerchief or not.
Sample Input
Sample Output
我共写了三个代码,不同的地方只有输入输出;但是AC的时间差别真的很大;问题在于cin与scanf,cout与printf;
贴出下面4个代码,以及其运行时间:
代码一:
#include <iostream>
using namespace std;
int gcd(int x, int y){return (y)?gcd(y,x%y):x;}
int main()
{
int N,M;
while(cin>>N>>M)
{
if(M==-1 && N==-1)break;
if(gcd(N,M)==1)cout<<"YES"<<endl;
else
cout<<"POOR Haha"<<endl;
}
}
代码二:
#include <iostream>
using namespace std;
int gcd(int x, int y){return (y)?gcd(y,x%y):x;}
int main()
{
int N,M;
while(scanf("%d%d",&N,&M),(N!=-1 && M!=-1))
{
if(gcd(N,M)==1)cout<<"YES"<<endl;
else
cout<<"POOR Haha"<<endl;
}
}
代码三:
#include <iostream>
using namespace std;
int gcd(int x, int y){return (y)?gcd(y,x%y):x;}
int main()
{
int N,M;
while(scanf("%d%d",&N,&M),(N!=-1 && M!=-1))
{
if(gcd(N,M)==1)printf("YES\n");
else
printf("POOR Haha\n");
}
}
代码四:
#include <iostream>
using namespace std;
int gcd(int x, int y){return (y)?gcd(y,x%y):x;}
int main()
{
int N,M;
while(scanf("%d%d",&N,&M),(N!=-1 && M!=-1))
{
if(gcd(N,M)==1)puts("YES");
else
puts("POOR Haha");
}
}
得出结论,scanf比cin快好多,printf比cout也快很多,当然这应该也是总所周知的;还有就是puts()比printf()略快;