HDU5011:Game(博弈)

Problem Description
Here is a game for two players. The rule of the game is described below: 

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing) 

● If after a player's turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
 

Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 10 5) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer a i(a i < 2 31) means there are a i beads in the i-th pile.
 



Output
For each test case, if the first player can win the game, ouput "Win" and if he can't, ouput "Lose"
 

Sample Input
   
   
   
   
1 1 2 1 1 3 1 2 3
 

Sample Output
   
   
   
   
Win Lose Lose
类似Nim博弈,胜负判断我也是靠猜的- -
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <algorithm>
using namespace std;
#define ll __int64
#define up(i,x,y) for(i=x;i<=y;i++)
#define up2(i,x,y) for(i=x;y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define down2(i,x,y) for(i=x;y;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define ss(a) scanf("%d",&a)
#define s64(a) scanf("%I64d",&a)
#define w(a) while(a)

int main()
{
    int a,s,i,n;
    w(~ss(n))
    {
        s=0;
        up(i,0,n-1)
        {
            ss(a);
            s^=a;
        }
        if(s)
            printf("Win\n");
        else
            printf("Lose\n");
    }

    return 0;
}


你可能感兴趣的:(HDU,博弈)