HDU 5973 ICPC 大连 Game of Taking Stones

Game of Taking Stones

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 542    Accepted Submission(s): 80


Problem Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?
 

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
 

Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
 

Sample Input
 
   
2 1 8 4 4 7
 

Sample Output
 
   
0 1 0

题目大意:


纯威佐夫博弈。不过要用大数来处理。

还要将  根号下 5 +1    /   2  精确到小数点后 100 多位才可以。


思路:


二分迭代求根号。java 直接写。


AC代码:


import java.math.BigDecimal;
import java.util.Scanner;

public class Main
{

	public static void main(String[] args)
	{
		BigDecimal TWO = BigDecimal.valueOf(2);
		BigDecimal FIVE = BigDecimal.valueOf(5);

		BigDecimal EPS = new BigDecimal(
				"-0.0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");

		BigDecimal l = new BigDecimal("2.2360679774997"), r = new BigDecimal("2.2360679774998");
		BigDecimal m = null;

		while (l.subtract(r).compareTo(EPS) < 0)
		{
			m = l.add(r).divide(TWO);
			if (m.multiply(m).subtract(FIVE).abs().compareTo(EPS.abs()) < 0)
				break;
			if (m.multiply(m).subtract(FIVE).compareTo(EPS) < 0)
				l = m;
			else
				r = m;
		}


		BigDecimal GOLD = m.add(BigDecimal.ONE).divide(TWO);

		Scanner sc = new Scanner(System.in);
		while (sc.hasNext())
		{
			BigDecimal a = sc.nextBigDecimal(), b = sc.nextBigDecimal();
			if (a.compareTo(b) > 0)
			{
				BigDecimal t = a;
				a = b;
				b = t;
			}

			BigDecimal c = b.subtract(a).setScale(0, BigDecimal.ROUND_FLOOR).multiply(GOLD);
			c = c.setScale(0, BigDecimal.ROUND_FLOOR);
			if (a.equals(c))
				System.out.println("0");
			else
				System.out.println("1");
		}
		sc.close();
	}
}


http://blog.csdn.net/dpppbr/article/details/53040770      参考自

你可能感兴趣的:(博弈论)