大菲波数(递推 + JAVA大数)

大菲波数
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20446 Accepted Submission(s): 6901

Problem Description
Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3。
计算第n项Fibonacci数值。

Input
输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。

Output
输出为N行,每行为对应的f(Pi)。

Sample Input

5
1
2
3
4
5

Sample Output

1
1
2
3
5

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        int ncase;
        Scanner cin = new Scanner(System.in);
        BigInteger []pp = new BigInteger[1001];
        ncase = cin.nextInt();
        pp[1] = BigInteger.ONE;
        pp[2] = BigInteger.ONE;
        for(int i = 3;i<=1000;i++)
        {
            pp[i] = pp[i-1].add(pp[i-2]);
        }
        while(ncase-->0)
        {
            int n ;
            n = cin.nextInt();
            System.out.println(pp[n]);
        }
    }

}

你可能感兴趣的:(大数问题,递推,大数问题,递推)