HDOJ 1008-Elevator【数学】



Elevator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5721 Accepted Submission(s): 2870

 
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 
Output
Print the total time on a single line for each test case.  
 
Sample Input
1 2
3 2 3 1
0
 
Sample Output
17
41
 
Author
ZHENG, Jianqiang
 




解题思路

题目大意就是有一个电梯,他停留每一次需要5秒,上升一次6秒,下降一次4秒。

<span style="font-size:18px;">#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)&&n)
	{
		int s=n*5,t=0;
		while(n--)
		{
			int a,b,c;
			scanf("%d",&a);
			if(a-t>0)
			{
				s=s+(a-t)*6;
			}
			if(a-t<0)
			{
				s=s+(t-a)*4;
			}
			t=a;
		}
		printf("%d\n",s);
	}
	return 0;
}</span>

你可能感兴趣的:(数学,hdoj)