hdu 1028 Ignatius and the Princess III(动态规划)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17069    Accepted Submission(s): 12000


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
   
   
   
   
4 10 20
 

Sample Output
   
   
   
   
5 42 627
 

Author
Ignatius.L


方法一:完全背包

可以将n当做 背包容量,1到n当做物品的体积;

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <cmath>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <stack>
const double PI = acos(-1.0);
using namespace std;
#define esp  1e-8
const int inf = 99999999;
//freopen("in.txt","r",stdin); //输入重定向,输入数据将从in.txt文件中读取
//freopen("out.txt","w",stdout); //输出重定向,输出数据将保存在out.txt文件中
int dp[122];
void init()
{
	memset(dp, 0, sizeof(dp));
	dp[0] = 1;
	for (int i = 1; i <= 120; ++i)
	{
		for (int j = i; j <= 120; ++j) //完全背包
			dp[j] += dp[j - i];
	}
}
int main()
{
	init();
	int n;
	while (~scanf("%d", &n))
		cout << dp[n] << endl;
}

方法二,用个dp[i][j] 来表示数位i,拆成j个数的方法数

    if (i >j) d[i][j] = d[i-j][j] + d[i][j-1]; 意思就是如果i>j,那么有两种方式:一种是先把i里面分理处j个1,然后再把i-j拆成最多i-j个数字;另一种是把i拆分成最多j-1个数字。

  if (i < j) d[i][j] = d[i][i]; 意思就是如果i<j,那么这种情况和把数字i最多拆成i个数字的是一样的。

  if (i == j) d[i][j] = d[i][j-1] + 1; 意思就是如果i==j,那么可以把数字i拆分成j-1个数字,也可以把数字i拆分成i个1(这个就是那个1的意义)


#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <cmath>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <stack>
const double PI = acos(-1.0);
using namespace std;
#define esp  1e-8
const int inf = 99999999;
//freopen("in.txt","r",stdin); //输入重定向,输入数据将从in.txt文件中读取
//freopen("out.txt","w",stdout); //输出重定向,输出数据将保存在out.txt文件中
int dp[122][122];
void init()
{
	memset(dp, 0, sizeof(dp));
	for (int i = 1; i <= 120; ++i)
		dp[i][1] = 1;
	for (int i = 1; i <= 120; ++i)
	{
		for (int j = 1; j <= 120; ++j)
		{
			if (i > j)
				dp[i][j] = dp[i - j][j] + dp[i][j - 1];
			else if (i == j)
				dp[i][j] = dp[i][i - 1] + 1;
			else
				dp[i][j] = dp[i][i];
		}
	}
}
int main()
{
	init();
	int n;
	while (~scanf("%d", &n))
		cout << dp[n][n] << endl;
}

其实还可以用母函数做,具体的百度吧,嘿嘿(其实是我不会)

你可能感兴趣的:(hdu 1028 Ignatius and the Princess III(动态规划))