九度_题目1390:矩形覆盖

题目描述:
我们可以用2*1的小矩形横着或者竖着去覆盖更大的矩形。请问用n个2*1的小矩形无重叠地覆盖一个2*n的大矩形,总共有多少种方法?
输入:
输入可能包含多个测试样例,对于每个测试案例,
输入包括一个整数n(1<=n<=70),其中n为偶数。
输出:
对应每个测试案例,
输出用n个2*1的小矩形无重叠地覆盖一个2*n的大矩形,总共有的方法数。
样例输入:
4
样例输出:

5

#include<iostream>
using namespace std;
int main()
{
    long long fib[70];
    fib[0]=1,fib[1]=2;
    for(int i=2;i<70;i++)
        fib[i]=fib[i-1]+fib[i-2];
    int num=0;
    while(cin>>num)
        cout<<fib[num-1]<<endl;
    return 0;
}
 
/**************************************************************
    Problem: 1390
    User: hndxztf
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1520 kb
****************************************************************/



你可能感兴趣的:(矩形覆盖)