Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Problem Description
In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.
You find a partial tree on the way home. This tree has n nodes but lacks of n−1 edges. You want to complete this tree by adding n−1 edges. There must be exactly one path between any two nodes after adding. As you know, there are nn−2 ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What’s the maximum coolness of the completed tree?
Input
The first line contains an integer T indicating the total number of test cases.
Each test case starts with an integer n in one line,
then one line with n−1 integers f(1),f(2),…,f(n−1).
1≤T≤2015
2≤n≤2015
0≤f(i)≤10000
There are at most 10 test cases with n>100.
Output
For each test case, please output the maximum coolness of the completed tree in one line.
Sample Input
2
3
2 1
4
5 1 4
Sample Output
5
19
题目链接:HDU-5534
题目大意:让你构造一个有n(2≤n≤2015)个节点的树。然后定义这棵树的coolness为∑f(d),其中d是每个节点的度数,函数f在输入中给出。
题目思路:一颗含有n个节点的树,有n−1条边,度数之和为2n−2。所以我们可以转化成一个完全背包问题:
一开始假设大家的度数都为1,然后慢慢地增大,让大家的度数和增大到2n−2。
dp[i]表示i个度的最优值
那么有状态转移方程:dp[i + j - 1] = max(dp[i + j - 1],dp[j] + num[i] - num[1]);
最终所求的答案就是dp[n-2]
以下是代码:
#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
int num[2050];
int dp[2050];
int n;
#define INF 0x3f3f3f3f
void solve()
{
for (int i = 0; i <= n; i++) dp[i] = -INF; //初始化
dp[0] = 0;
for (int i = 2; i < n; i++)
{
for (int j = 0; i + j - 1 <= n - 2; j++)
{
dp[i + j - 1] = max(dp[i + j - 1],dp[j] + num[i] - num[1]);
}
}
}
int main(){
int t;
cin >> t;
while(t--)
{
scanf("%d",&n);
memset(dp,0,sizeof(dp));
memset(num,0,sizeof(num));
for (int i = 1; i <= n - 1; i++)
{
scanf("%d",&num[i]);
}
solve();
int ans = dp[n - 2] + num[1] * n;
printf("%d\n",ans);
}
return 0;
}