Usaco 3.1Agri-Net(MST)

————————————————————————————————————————————————————————————
PS:这大水题就不说了吧,胡搞,随便写都能过的,LRJ老师书上的模板。。。。。 我写的Kruscal。。。。

Agri-Net
Russ Cox

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

PROGRAM NAME: agrinet

INPUT FORMAT

Line 1: The number of farms, N (3 <= N <= 100).
Line 2..end: The subsequent lines contain the N x N connectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

SAMPLE INPUT (file agrinet.in)

40 4 9 214 0 8 179 8 0 1621 17 16 0

OUTPUT FORMAT

The single output contains the integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

SAMPLE OUTPUT (file agrinet.out)

28
/*
ID:shi13891
PROG:agrinet
LANG:C++
*/
#include<iostream>
#include<fstream>
#include<algorithm>

#define INF 0xfffffff
using namespace std;

int n,edge_weight,t=0,ans=0;

int p[10005],r[10005];
int u[10005],v[10005],w[10005];
 

bool cmp(int i,int j)
{
    return w[i]<w[j];
}
 

int find(int x)
{
    return p[x]==x?x:p[x]=find(p[x]);
}
 

int kruscal()
{
 int ans=0;
 for(int i=0;i<t;i++)
    p[i]=i;
 for(int i=0;i<t;i++)
    r[i]=i;
 sort(r,r+t,cmp);
 for(int i=0;i<t;i++)
 {
    int e=r[i];
    int x=find(u[e]);
    int y=find(v[e]);
    if(x!=y)
    {
      ans+=w[e];
      p[x]=y;
    }
 }
 return ans;
}

int main()
{
    freopen("agrinet.in","r",stdin);
    freopen("agrinet.out","w",stdout);
    cin >> n;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            cin>>edge_weight;
            u[t]=i;
            v[t]=j;
            w[t]=edge_weight;
            t++;
        }
    }
    cout<<kruscal()<<endl;
    return 0;
}

/*第一次这么写Kruscal。。。。*/


你可能感兴趣的:(Usaco 3.1Agri-Net(MST))