UVA - 1434 YAPTCHA (威尔逊定理)

Description

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-PublicTuring-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.

However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a naturaln , compute

S n = -
where [x] denotes the largest integer not greater than x .

Input 

The first line contains the number of queries t(t106) . Each query consist of one natural number n(1n106) .

Output 

For each n given in the input output the value ofSn .

Sample Input 

13 
1 
2 
3 
4 
5 
6 
7 
8 
9 
10 
100 
1000 
10000

Sample Output

0 
1 
1 
2 
2 
2 
2 
3 
3 
4 
28 
207 
1609
题意:输入正整数,计算 S n = -

思路:首先明白一个威尔逊定理:威尔逊定理给出了判定一个自然数是否为素数的充分必要条件。即:当且仅当p为素数时:( p -1 )! ≡ -1 ( mod p ),所以我们可以判断的是只有当

3*k+7是素数的时候,才能有1的结果,否则是0

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;
const int maxn = 5000005;
const int maxm = 1000005;

int vis[maxn], sum[maxn];

void init() {
	memset(vis, 0, sizeof(vis));
	vis[0] = vis[1] = 1;
	for (ll i = 2; i < maxn; i++)
		if (!vis[i]) {
			for (ll j = i*i; j < maxn; j += i)
				vis[j] = 1;
		}
	for (int i = 1; i < maxm; i++)
		if (vis[3*i+7] == 0)
			sum[i] = 1;
		else sum[i] = 0;
	for (int i = 2; i < maxm; i++)
		sum[i] += sum[i-1];
}

int main() {
	init();
	int t, n;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		printf("%d\n", sum[n]);
	}
}



你可能感兴趣的:(UVA - 1434 YAPTCHA (威尔逊定理))